import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(SAIL_Recipes\\.md)(\\#)(.*?)(?=\\))";
final String string = "\n"
+ "Now instead of numbers in the status column, there are words like *Assigned* and *Completed*. For an example that uses an image column to display an icon for process statuses, see the [Display Processes by Process Model with Status Icons](SAIL_Recipes.md#Display_Processes_by_Process_Model_with_Status_Icons) SAIL recipe.\n\n"
+ "## <a id=\"Add_a_Predefined_Filter\"></a> Add a Predefined Filter ##\n\n"
+ "(#Display_Processes_by_Process_Model_with_Status_Icons) SAIL recipe.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}