re = /(?:\s|^)@\w+/
str = '@SomeUselessText
test @SomeUselessText
info@SomeSite.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end