#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?:^|(?<=\s)) # delimitador inicial" & @CRLF & _
"[+-]?[0-9]+ # entero con o sin signo" & @CRLF & _
"(?=\s) # delimitador de finalización"
Local $sString = "Hace coincidir números enteros aislados para el sistema de numeración decimal." & @CRLF & _
"test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")