using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?<=\s)) # delimitador inicial
[+-]?[0-9]+ # entero con o sin signo
(?=\s) # delimitador de finalización";
string input = @"Hace coincidir números enteros aislados para el sistema de numeración decimal.
test: 11 +11 -11 99-99 a99 a+99 a-99 99a +99a -99a";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}