import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.\\s?)(\\d{2}\\s?)(\\d{1})(.?\\s)(\\d{3}.?)(\\d{4})$";
final String string = "+63 2 123 4567\n"
+ "+632 456-7890\n"
+ "+632 4567890\n"
+ "(632) 987 6543";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}