// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<a.*href=(("|')(.*pdf)("|')))"#).unwrap();
let string = "<a href=\"https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf\">Un Lienn</a>";
let substitution = "$1 download";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}