$re = '/^(C3-)(\d)$/m';
$str = 'C3-1';
$subst = "\g<1>000\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;