import Foundation
let pattern = #"^(C3-)(\d)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"C3-1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<1>000\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)