const regex = /^ *(?:--)([\w-]+)(?:=((?:[\w-]| \w)+))?|(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ *(?:--)([\\w-]+)(?:=((?:[\\w-]| \\w)+))?|(.*)', 'gm')
const str = `--match1=match2
--match1=match2 match2
--match1=match2 match2-match2
--mat-ch1=match2 match2
--match1=match2-match2 match2
--match1=match2 -lastmatch
--match1=match2 --lastmatch
--match1 -lastmatch
--match1 --lastmatch
lastormatch`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}