#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(^Project\("{[a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12}}"\)\s*=\s*"[\w\d-.]*"\s*,\s*")\K([\w\d-.\\\s]*)(?=".*$)"
Local $sString = "Microsoft Visual Studio Solution File, Format Version 12.00" & @CRLF & _
"# Visual Studio 14" & @CRLF & _
"VisualStudioVersion = 14.0.25420.1" & @CRLF & _
"MinimumVisualStudioVersion = 10.0.40219.1" & @CRLF & _
"Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "CCH.WFM.UnitTest.Framework", "Source\Common\Tests\Unit Tests\WFMTestFramework\CCH.WFM.UnitTest.Framework.csproj", "{044E36A5-189E-45B1-9753-397BC8ACD31A}"" & @CRLF & _
"EndProject" & @CRLF & _
"Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "CCH.WFM.ServiceTest", "Source\Common\Tests\Unit Tests\ServiceTest\CCH.WFM.ServiceTest.csproj", "{94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}"" & @CRLF & _
"EndProject" & @CRLF & _
"Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "TestFramework", "..\test\TestFramework\TestFramework.csproj", "{3F56B03C-0883-4705-91BA-0979CAF6E719}"" & @CRLF & _
"EndProject" & @CRLF & _
"Global" & @CRLF & _
" GlobalSection(SolutionConfigurationPlatforms) = preSolution" & @CRLF & _
" Debug|Any CPU = Debug|Any CPU" & @CRLF & _
" Release|Any CPU = Release|Any CPU" & @CRLF & _
" EndGlobalSection" & @CRLF & _
" GlobalSection(ProjectConfigurationPlatforms) = postSolution" & @CRLF & _
" {044E36A5-189E-45B1-9753-397BC8ACD31A}.Debug|Any CPU.ActiveCfg = Debug|Any CPU" & @CRLF & _
" {044E36A5-189E-45B1-9753-397BC8ACD31A}.Debug|Any CPU.Build.0 = Debug|Any CPU" & @CRLF & _
" {044E36A5-189E-45B1-9753-397BC8ACD31A}.Release|Any CPU.ActiveCfg = Release|Any CPU" & @CRLF & _
" {044E36A5-189E-45B1-9753-397BC8ACD31A}.Release|Any CPU.Build.0 = Release|Any CPU" & @CRLF & _
" {94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Debug|Any CPU.ActiveCfg = Debug|Any CPU" & @CRLF & _
" {94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Debug|Any CPU.Build.0 = Debug|Any CPU" & @CRLF & _
" {94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Release|Any CPU.ActiveCfg = Release|Any CPU" & @CRLF & _
" {94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Release|Any CPU.Build.0 = Release|Any CPU" & @CRLF & _
" {3F56B03C-0883-4705-91BA-0979CAF6E719}.Debug|Any CPU.ActiveCfg = Debug|Any CPU" & @CRLF & _
" {3F56B03C-0883-4705-91BA-0979CAF6E719}.Debug|Any CPU.Build.0 = Debug|Any CPU" & @CRLF & _
" {3F56B03C-0883-4705-91BA-0979CAF6E719}.Release|Any CPU.ActiveCfg = Release|Any CPU" & @CRLF & _
" {3F56B03C-0883-4705-91BA-0979CAF6E719}.Release|Any CPU.Build.0 = Release|Any CPU" & @CRLF & _
" EndGlobalSection" & @CRLF & _
" GlobalSection(SolutionProperties) = preSolution" & @CRLF & _
" HideSolutionNode = FALSE" & @CRLF & _
" EndGlobalSection" & @CRLF & _
" GlobalSection(TeamFoundationVersionControl) = preSolution" & @CRLF & _
" SccNumberOfProjects = 4" & @CRLF & _
" SccEnterpriseProvider = {4CA58AB2-18FA-4F8D-95D4-32DDF27D184C}" & @CRLF & _
" SccTeamFoundationServer = https://tfs2013.prosystemfx.com/tfs/nextgen" & @CRLF & _
" SccLocalPath0 = ." & @CRLF & _
" SccProjectUniqueName1 = Source\\Common\\Tests\\Unit\u0020Tests\\WFMTestFramework\\CCH.WFM.UnitTest.Framework.csproj" & @CRLF & _
" SccProjectName1 = Source/Common/Tests/Unit\u0020Tests/WFMTestFramework" & @CRLF & _
" SccLocalPath1 = Source\\Common\\Tests\\Unit\u0020Tests\\WFMTestFramework" & @CRLF & _
" SccProjectUniqueName2 = Source\\Common\\Tests\\Unit\u0020Tests\\ServiceTest\\CCH.WFM.ServiceTest.csproj" & @CRLF & _
" SccProjectName2 = Source/Common/Tests/Unit\u0020Tests/ServiceTest" & @CRLF & _
" SccLocalPath2 = Source\\Common\\Tests\\Unit\u0020Tests\\ServiceTest" & @CRLF & _
" SccProjectUniqueName3 = ..\\test\\TestFramework\\TestFramework.csproj" & @CRLF & _
" SccProjectName3 = ../test/TestFramework" & @CRLF & _
" SccLocalPath3 = ..\\test\\TestFramework" & @CRLF & _
" EndGlobalSection" & @CRLF & _
"EndGlobal" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")