# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^Project\(\"{[a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12}}\"\)\s*=\s*\"[\w\d-.]*\"\s*,\s*\")\K([\w\d-.\\\s]*)(?=\".*$)"
test_str = ("Microsoft Visual Studio Solution File, Format Version 12.00\n"
"# Visual Studio 14\n"
"VisualStudioVersion = 14.0.25420.1\n"
"MinimumVisualStudioVersion = 10.0.40219.1\n"
"Project(\"{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}\") = \"CCH.WFM.UnitTest.Framework\", \"Source\\Common\\Tests\\Unit Tests\\WFMTestFramework\\CCH.WFM.UnitTest.Framework.csproj\", \"{044E36A5-189E-45B1-9753-397BC8ACD31A}\"\n"
"EndProject\n"
"Project(\"{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}\") = \"CCH.WFM.ServiceTest\", \"Source\\Common\\Tests\\Unit Tests\\ServiceTest\\CCH.WFM.ServiceTest.csproj\", \"{94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}\"\n"
"EndProject\n"
"Project(\"{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}\") = \"TestFramework\", \"..\\test\\TestFramework\\TestFramework.csproj\", \"{3F56B03C-0883-4705-91BA-0979CAF6E719}\"\n"
"EndProject\n"
"Global\n"
" GlobalSection(SolutionConfigurationPlatforms) = preSolution\n"
" Debug|Any CPU = Debug|Any CPU\n"
" Release|Any CPU = Release|Any CPU\n"
" EndGlobalSection\n"
" GlobalSection(ProjectConfigurationPlatforms) = postSolution\n"
" {044E36A5-189E-45B1-9753-397BC8ACD31A}.Debug|Any CPU.ActiveCfg = Debug|Any CPU\n"
" {044E36A5-189E-45B1-9753-397BC8ACD31A}.Debug|Any CPU.Build.0 = Debug|Any CPU\n"
" {044E36A5-189E-45B1-9753-397BC8ACD31A}.Release|Any CPU.ActiveCfg = Release|Any CPU\n"
" {044E36A5-189E-45B1-9753-397BC8ACD31A}.Release|Any CPU.Build.0 = Release|Any CPU\n"
" {94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Debug|Any CPU.ActiveCfg = Debug|Any CPU\n"
" {94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Debug|Any CPU.Build.0 = Debug|Any CPU\n"
" {94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Release|Any CPU.ActiveCfg = Release|Any CPU\n"
" {94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Release|Any CPU.Build.0 = Release|Any CPU\n"
" {3F56B03C-0883-4705-91BA-0979CAF6E719}.Debug|Any CPU.ActiveCfg = Debug|Any CPU\n"
" {3F56B03C-0883-4705-91BA-0979CAF6E719}.Debug|Any CPU.Build.0 = Debug|Any CPU\n"
" {3F56B03C-0883-4705-91BA-0979CAF6E719}.Release|Any CPU.ActiveCfg = Release|Any CPU\n"
" {3F56B03C-0883-4705-91BA-0979CAF6E719}.Release|Any CPU.Build.0 = Release|Any CPU\n"
" EndGlobalSection\n"
" GlobalSection(SolutionProperties) = preSolution\n"
" HideSolutionNode = FALSE\n"
" EndGlobalSection\n"
" GlobalSection(TeamFoundationVersionControl) = preSolution\n"
" SccNumberOfProjects = 4\n"
" SccEnterpriseProvider = {4CA58AB2-18FA-4F8D-95D4-32DDF27D184C}\n"
" SccTeamFoundationServer = https://tfs2013.prosystemfx.com/tfs/nextgen\n"
" SccLocalPath0 = .\n"
" SccProjectUniqueName1 = Source\\\\Common\\\\Tests\\\\Unit\\u0020Tests\\\\WFMTestFramework\\\\CCH.WFM.UnitTest.Framework.csproj\n"
" SccProjectName1 = Source/Common/Tests/Unit\\u0020Tests/WFMTestFramework\n"
" SccLocalPath1 = Source\\\\Common\\\\Tests\\\\Unit\\u0020Tests\\\\WFMTestFramework\n"
" SccProjectUniqueName2 = Source\\\\Common\\\\Tests\\\\Unit\\u0020Tests\\\\ServiceTest\\\\CCH.WFM.ServiceTest.csproj\n"
" SccProjectName2 = Source/Common/Tests/Unit\\u0020Tests/ServiceTest\n"
" SccLocalPath2 = Source\\\\Common\\\\Tests\\\\Unit\\u0020Tests\\\\ServiceTest\n"
" SccProjectUniqueName3 = ..\\\\test\\\\TestFramework\\\\TestFramework.csproj\n"
" SccProjectName3 = ../test/TestFramework\n"
" SccLocalPath3 = ..\\\\test\\\\TestFramework\n"
" EndGlobalSection\n"
"EndGlobal\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.