use strict;
my $str = '02_AUT/TTF_H_CYL_PHY 2015
02_AUT/TTF_H_CYL_PHY 2016
02_GASPOOL_L/GASPOOL_H_CYL_PHY 2015
02_GASPOOL_L/GASPOOL_H_CYL_PHY 2016';
my $regex = qr/^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'CY)(?'offset'L)_(?'derivative'PHY|FUT) (?'period')(?'year'\d{4})\b$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}