import Foundation
let pattern = #"(...)(\/([nsbpif]))+ ([\d])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Aaa/n 0
Bbb/b/p 0
Ccc/b/n/p 3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@"$1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)