#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<value>[\s\S]*?(([0-2]?[0-9]?[0-9]\.){3}([0-2]?[0-9]?[0-9]))[\s\S]*?<\/value>"
Local $sString = "<value>activemq:tcp://192.168.0.172:61616?transport.useInactivityMonitor=false</value>" & @CRLF & _
"<value>192.168.0.172</value>"
Local $sSubst = "{$1 $2 $3}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)