using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<value>[\s\S]*?(([0-2]?[0-9]?[0-9]\.){3}([0-2]?[0-9]?[0-9]))[\s\S]*?<\/value>";
string substitution = @"{$1 $2 $3}";
string input = @"<value>activemq:tcp://192.168.0.172:61616?transport.useInactivityMonitor=false</value>
<value>192.168.0.172</value>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}