use strict;
my $str = '<value>activemq:tcp://192.168.0.172:61616?transport.useInactivityMonitor=false</value>
<value>192.168.0.172</value>';
my $regex = qr/<value>[\s\S]*?(([0-2]?[0-9]?[0-9]\.){3}([0-2]?[0-9]?[0-9]))[\s\S]*?<\/value>/p;
my $subst = '{$1 $2 $3}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";