re = /<value>[\s\S]*?(([0-2]?[0-9]?[0-9]\.){3}([0-2]?[0-9]?[0-9]))[\s\S]*?<\/value>/
str = '<value>activemq:tcp://192.168.0.172:61616?transport.useInactivityMonitor=false</value>
<value>192.168.0.172</value>'
subst = '{$1 $2 $3}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result