using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z]).{0,}$";
string input = @"Pass1234
Pass1234
pass
PASS
papsssssss
PASS1234
Pass123444khgvdfvzkeavfzeZRRGGRTTRGTRGZERgzefefrfr898888zr88r88
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}