package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,2})h(?:\s?(\d{1,2})m)?`)
var str = `8h 20m left
42m left
7h left
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}