$re = '~^jdbc:postgresql:(?://[^/]+/)?(\w+)~m';
$str = 'jdbc:postgresql:databasename
jdbc:postgresql://host/database_a
jdbc:postgresql://host:5432/database_123
jdbc:postgresql://localhost/database?user=fred&password=secret&ssl=true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);