re = /<table\b[^\>]*\bname=(\"|')?table01\1[^\>]*>(?>([^\<]+|<(?!\/?table\b))|(<table[^\>]*>(?:(?2)|(?3)|)+?<\/table>))*<\/table>/ix
str = '<table name="table01" data-measure-unit="Y">
<table></table>
</table>
<table name="table01" data-measure-unit="Y">
<div>
<table></table>
</div>
</table>
<table name="table01" data-measure-unit="Y">
<div>
<table>
<table>
</table>
</table>
</div>
</table>
<table name="table01" data-measure-unit="Y">
<div>
<div></div>
</div>
</table>
<table name="table01" data-measure-unit="Y">
</table>
<table name="table01"></table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end