import Foundation
let pattern = #"\s*\[.*?[^\[]*\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Duck, Donald [CTO [Enterprise] some] Mouse, Micky [HR Employee Engagement]
Duck, Donald [[Enterprise] some] Mouser, Virus [HR Employee Engagement]
Duck, Donald [[Enterprise] [some]] Random text, Virus [HR Employee Engagement]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)