re = /SID=\w*/
str = 'admin.php?user=alireza&sa=y&SID=0ahUKEwiO3u2Ji&access=14587&commment=yes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end