import Foundation
let pattern = #"^([^.]+)\_([^.]+)\_([^.]+)\_([^.]+)\_([^.]+)\.fastq$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A10_S65_L001_R1_001.fastq
A8_S49_L001_R2_001.fastq
B7_S42_L001_R1_001.fastq
C5_S27_L001_R2_001.fastq
F4_S22_L001_R1_001.fastq
G2_S7_L001_R2_001.fastq
H1_S165_L001_R1_001.fastq
A10_S65_L001_R2_001.fastq
A9_S57_L001_R1_001.fastq
B7_S42_L001_R2_001.fastq
C6_S35_L001_R1_001.fastq
F4_S22_L001_R2_001.fastq
G3_S15_L001_R1_001.fastq
H1_S165_L001_R2_001.fastq
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_$4.fastq"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)