#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^msgstr (?:"[^"\r\n]+"|.*(?:\n".*")+)"
Local $sString = "msgstr "some text"" & @CRLF & _
"or which spread on several lines:" & @CRLF & _
"" & @CRLF & _
"msgstr """ & @CRLF & _
""some multiline text"" & @CRLF & _
""goes here"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"but not empty ones:" & @CRLF & _
"" & @CRLF & _
"msgstr """
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")