package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/szukaj\/(?'query'[a-zA-ZąćęłńóśźżĄĆĘŁŃÓŚŹŻ-]+)`)
var str = `/szukaj/zwierzeta
/szukaj/zwierzęta`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}