$re = '/\/szukaj\/(?\'query\'[a-zA-ZąćęłńóśźżĄĆĘŁŃÓŚŹŻ-]+)/';
$str = '/szukaj/zwierzeta
/szukaj/zwierzęta';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);