use strict;
my $str = '<h1 id="--the-instagram-photo-feed"><img alt="alt text" src="https://assets.breatheco.de/apis/img/images.php?blob&random&cat=icon&tags=breathecode,32" class="MDImg"> The Instagram Photo Feed</h1>';
my $regex = qr/(?!>)([^><]+)(?=<\/h[0-9]>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}