import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\?.*[\\s\\S]*?(?:$|\\?\\>)";
final String string = "<?php foo(); ?>\n\n"
+ "<abc>\n\n"
+ "<? foo(); ?>\n\n"
+ "<?php\n\n"
+ "foo();\n"
+ "bar();\n\n"
+ "?>\n\n"
+ "foo();\n"
+ "bar();\n\n"
+ "<? //also short open tag\n\n"
+ "foo();\n"
+ "bar();\n\n"
+ "?><?php\n\n"
+ "foo();\n"
+ "bar();\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}