import Foundation
let pattern = #"<\?.*[\s\S]*?(?:$|\?\>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<?php foo(); ?>
<abc>
<? foo(); ?>
<?php
foo();
bar();
?>
foo();
bar();
<? //also short open tag
foo();
bar();
?><?php
foo();
bar();
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)