#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])$"
Local $sString = "0.0.0.0" & @CRLF & _
"192.168.1.1" & @CRLF & _
"127.0.0.1" & @CRLF & _
"255.255.255.255" & @CRLF & _
"9.9.9.253" & @CRLF & _
"1.1.1.1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"256.0.0.0" & @CRLF & _
"0.256.0.0" & @CRLF & _
"0.0.256.0" & @CRLF & _
"0.0.0.256" & @CRLF & _
".0.0.0.0" & @CRLF & _
"0.0.0.0." & @CRLF & _
"a.a.a.a" & @CRLF & _
"-1.-1.-1.-1" & @CRLF & _
"256.256.256.256" & @CRLF & _
"^(\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b\.\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b\.\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b\.\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\b)$" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"1." & @CRLF & _
"1.1" & @CRLF & _
"1.1" & @CRLF & _
"1.1." & @CRLF & _
"1.1.1" & @CRLF & _
"1.1.1." & @CRLF & _
"1.1.1.1" & @CRLF & _
"1.1.1.1." & @CRLF & _
"1.1.1.1.1" & @CRLF & _
"20" & @CRLF & _
"20." & @CRLF & _
"20.20" & @CRLF & _
"20.20." & @CRLF & _
"20.20.20" & @CRLF & _
"20.20.20." & @CRLF & _
"20.20.20.20" & @CRLF & _
"20.20.20.20." & @CRLF & _
"20.20.20.20.20" & @CRLF & _
"300" & @CRLF & _
"300." & @CRLF & _
"300.300" & @CRLF & _
"300.300." & @CRLF & _
"300.300.300" & @CRLF & _
"300.300.300." & @CRLF & _
"300.300.300.300" & @CRLF & _
"300.300.300.300." & @CRLF & _
"300.300.300.300.300" & @CRLF & _
"4000" & @CRLF & _
"4000." & @CRLF & _
"4000.4000" & @CRLF & _
"4000.4000." & @CRLF & _
"4000.4000.4000" & @CRLF & _
"4000.4000.4000." & @CRLF & _
"4000.4000.4000.4000" & @CRLF & _
"4000.4000.4000.4000." & @CRLF & _
"4000.4000.4000.4000.4000" & @CRLF & _
"amiraizat124@gmail.com" & @CRLF & _
"ak</';" & @CRLF & _
"1,1,1,1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")