const regex = new RegExp('^(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])[.](?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])$', 'gm')
const str = `0.0.0.0
192.168.1.1
127.0.0.1
255.255.255.255
9.9.9.253
1.1.1.1
256.0.0.0
0.256.0.0
0.0.256.0
0.0.0.256
.0.0.0.0
0.0.0.0.
a.a.a.a
-1.-1.-1.-1
256.256.256.256
^(\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b\\.\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b\\.\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b\\.\\b(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\\b)\$
1
1.
1.1
1.1
1.1.
1.1.1
1.1.1.
1.1.1.1
1.1.1.1.
1.1.1.1.1
20
20.
20.20
20.20.
20.20.20
20.20.20.
20.20.20.20
20.20.20.20.
20.20.20.20.20
300
300.
300.300
300.300.
300.300.300
300.300.300.
300.300.300.300
300.300.300.300.
300.300.300.300.300
4000
4000.
4000.4000
4000.4000.
4000.4000.4000
4000.4000.4000.
4000.4000.4000.4000
4000.4000.4000.4000.
4000.4000.4000.4000.4000
amiraizat124@gmail.com
ak</';
1,1,1,1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}