# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<meta[^>]+property=[\"']og:image[\"'][^>]+content=[\"']([^\"']*)[\"'][^>]*>"
test_str = ("<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">\n"
"<html xml:lang=\"ja\" lang=\"ja\" dir=\"ltr\" xmlns=\"http://www.w3.org/1999/xhtml\">\n"
"<head>\n"
"<title>CES2017:OtterBox、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」を展示 | レポート | Macお宝鑑定団 blog(羅針盤)</title>\n"
"<meta http-equiv=\"Content-Type\" content=\"text/html; charset=UTF-8\" />\n"
"<meta http-equiv=\"Content-Style-Type\" content=\"text/css\" />\n"
"<meta http-equiv=\"Content-Script-Type\" content=\"text/javascript\" />\n"
"<!-- ※ meta ※ -->\n"
"<meta property=\"og:locale\" content=\"ja_JP\" />\n"
"<meta property=\"og:url\" name=\"og:url\" content=\"http://www.macotakara.jp/blog/report/entry-31631.html?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A%20macotakara%2FzeST%20%28MAC%E3%81%8A%E5%AE%9D%E9%91%91%E5%AE%9A%E5%9B%A3%20blog%EF%BC%88%E7%BE%85%E9%87%9D%E7%9B%A4%EF%BC%89RSS2%29\" />\n"
"<meta property=\"og:site_name\" name=\"og:site_name\" content=\"Macお宝鑑定団 blog(羅針盤)\" />\n"
"<meta property=\"fb:admins\" content=\"1264128707\" />\n"
"<meta name=\"twitter:site\" content=\"@idanbo\" />\n"
"<meta name=\"twitter:creator\" content=\"@idanbo\">\n"
"<meta name=\"twitter:domain\" content=\"twitter.com/idanbo\">\n\n\n\n\n\n\n"
"<meta name=\"twitter:card\" content=\"summary_large_image\" />\n"
"<meta property=\"og:type\" name=\"og:type\" content=\"article\" />\n"
"<meta property=\"og:title\" name=\"og:title\" content=\"CES2017:OtterBox、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」を展示 | レポート | Macお宝鑑定団 blog(羅針盤)\" />\n"
"<meta name=\"twitter:title\" content=\"CES2017:OtterBox、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」を展示 | レポート | Macお宝鑑定団 blog(羅針盤)\" />\n\n\n"
"<meta property=\"og:description\" content=\"CES2017において、OtterBoxが、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」の展示を行っていました。 背面にあるスライド式「uniVERSEケースシステム」を使用して、背面の下半分を変更す...\" />\n"
"<meta name=\"twitter:description\" content=\"CES2017において、OtterBoxが、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」の展示を行っていました。 背面にあるスライド式「uniVERSEケースシステム」を使用して、背面の下半分を変更す...\" />\n"
"<meta name=\"description\" content=\"CES2017において、OtterBoxが、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」の展示を行っていました。 背面にあるスライド式「uniVERSEケースシステム」を使用して、背面の下半分を変更す...\" />\n"
"<meta property=\"og:image\" name=\"og:image\" content=\"http://www.macotakara.jp//blog/archives/001/201701/5871de9fb4929.jpg\" />\n"
"<meta name=\"twitter:image\" content=\"http://www.macotakara.jp//blog/archives/001/201701/5871de9fb4929.jpg\" />\n\n\n\n"
"<!-- ※ ogp ※ -->\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.