import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+ (\\d+ -[^\\-]+)( -.*)?$";
final String string = "Opcao 01 - Frase aleatória - Menu Superior\n"
+ "Opcao 02 - Outra Frase aleatória - Menu Su\n"
+ "Opcao 03 - Mais 01 Frase - Menu\n"
+ "Opcao 04 - Mais Frase -\n"
+ "Opcao 05 - Frase Simples";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}