# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*([^*]+)\*/<b>$1<\/b>/g;t' <<< "What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.
This line contains entries with numbers (*1+2=3*) and punctuation too (*this is a sentence.*)"