const regex = /\*([^*]+)\*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*([^*]+)\\*', 'g')
const str = `What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.
This line contains entries with numbers (*1+2=3*) and punctuation too (*this is a sentence.*)`;
const subst = `<b>$1</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);