#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]\d*(?:[-\s]?\w+)?$"
Local $sString = "25" & @CRLF & _
"25 a" & @CRLF & _
"25b" & @CRLF & _
"25-ab" & @CRLF & _
"12-14" & @CRLF & _
"Not valid house number:" & @CRLF & _
"" & @CRLF & _
"0" & @CRLF & _
"b" & @CRLF & _
"0a" & @CRLF & _
"00a" & @CRLF & _
"a a" & @CRLF & _
"00 a" & @CRLF & _
"13àâäèéêë"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")