using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]\d*(?:[-\s]?\w+)?$";
string input = @"25
25 a
25b
25-ab
12-14
Not valid house number:
0
b
0a
00a
a a
00 a
13àâä èéêë";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}