use strict;
my $str = 'http://tv.tvip-media.net/perviykanal/video.m3u8
http://tv.tvip-media.net:80/perviykanal/video.m3u8
udp://229.1.1.1:1234
http://udpxy.netsol.su:4022/udp/225.100.123.26:1234';
my $regex = qr/^(http[s]?|udp|rtp)\:\/\/+([a-z0-9._-]+(\:[0-9]+)?)(\/([a-zA-Z0-9_-]+|udp)\/(([a-zA-Z0-9_-]+)(.m3u8)|(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\:(\d{1,5}))?))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}