#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)FieldName=["'](.*?)["']"
Local $sString = " <dataGridWrapper:DataGridWrapperColumn FieldName="DateEcriture" Title="Date" Visible="True" ReadOnly="True" Width="70" AllowSort="False" DisplayFormat="dd/MM/yyyy"/>" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="CodeJournal" Title="Jrl" Visible="True" ReadOnly="True" Width="50" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="NoPiece" Title="N° Pièce" Visible="True" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="LibelleEcriture" Title="Libellé" Visible="True" ReadOnly="True" Width="180" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="Debit" Title="Débit" Visible="True" ReadOnly="True" Width="80" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="Credit" Title="Crédit" Visible="True" ReadOnly="True" Width="80" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="SoldeD" Title="Solde Débit" Visible="True" ReadOnly="True" Width="80" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="SoldeC" Title="Solde Crédit" Visible="True" ReadOnly="True" Width="80" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="Lettrage" Title="Lettrage" Visible="True" ReadOnly="True" Width="40" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="LibellePrestation" Title="Prestation" Visible="True" ReadOnly="True" Width="80" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="EtatPiece" Title="Etat" Visible="True" ReadOnly="True" Width="30" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="NomResidence" Title="Résidence" Visible="True" ReadOnly="True" Width="85" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="IDEcriture" Title="IDEcriture" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="IDImmeuble" Title="IDImmeuble" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="IDMandat" Title="IDMandat" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="NoAvisEcheance" Title="N° Echeance" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="NoFacture" Title="N° Facture" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="NoFolio" Title="N° Folio" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="NoLigne" Title="N° Ligne" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="NumMandant" Title="N° Mandat" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="Pointage" Title="Pointage" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="MarqueeCRG" Title="MarqueeCRG" Visible="False" ReadOnly="True" Width="60" AllowSort="False" />" & @CRLF & _
" <dataGridWrapper:DataGridWrapperColumn FieldName="MarqueeNoLot" Title="MarqueeNoLot" Visible="False" ReadOnly="True" Width="80" AllowSort="False" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")