# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/Network\\/Cambric Corporate Center\\/).{8}/$1/gm;t' <<< "/Network/Cambric Corporate Center/1164.DEV1164"