using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.*?)\.(.*?)(_\d$)";
string input = @"3052503155104.Bourjois_FDTAirMat_01_1
3052503155104.Bourjois_FDTAirMat_01_2
3052503155104.Bourjois_FDTAirMat_01_3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}