package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^.*?)\.(.*?)(_\d$)`)
var str = `3052503155104.Bourjois_FDTAirMat_01_1
3052503155104.Bourjois_FDTAirMat_01_2
3052503155104.Bourjois_FDTAirMat_01_3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}