use strict;
my $str = 'These are the scenarios that we can accept:
0.01
1.1
1.02
120.01
We can\'t accept these values
0023
0100
.01
.12
001.02
0000';
my $regex = qr/^(?!0\d*$)\d+(?:\.\d{1,2})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}