import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:|\\s)\\w+(?:\\.|))(?:|,|\\.)\\s(\\d+)";
final String string = "Av. Moinho Fabrini, 600 - Independencia, Sao Bernardo do Campo - SP, 09862-160\n"
+ "SAO BERNARDO DO CAMPO STATE OF SAO PAULO BRAZIL RUA VICENTE DE CARVALHO 197 09726 600\n"
+ "RUA JOAO PESSOA, 420, CENTRO, SAO BERNARDO DO CAMPO - SAO PAULO, 09715-000, BRASIL\n"
+ "AV. ROBERT KENNEDY. 3095 - ASSUNCAO SAO BERNARDO DO CAMPO - SP. 09860-215";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}