const regex = new RegExp('((?:|\\s)\\w+(?:\\.|))(?:|,|\\.)\\s(\\d+)', 'gm')
const str = `Av. Moinho Fabrini, 600 - Independencia, Sao Bernardo do Campo - SP, 09862-160
SAO BERNARDO DO CAMPO STATE OF SAO PAULO BRAZIL RUA VICENTE DE CARVALHO 197 09726 600
RUA JOAO PESSOA, 420, CENTRO, SAO BERNARDO DO CAMPO - SAO PAULO, 09715-000, BRASIL
AV. ROBERT KENNEDY. 3095 - ASSUNCAO SAO BERNARDO DO CAMPO - SP. 09860-215`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}