// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)TOTAL LEI (?P<TotalLei>\d+\.\d+)\s.*iD BF: (?P<iD_BF>\d+\s\d\s\d+)\s.*DATA: (?P<DATA>[^\s]+)\s").unwrap();
let string = "TOTAL LEI 90.00 | CARD 50.00 REST 0.00 TOTAL TUA A - 19% 1.92 TOTAL TAC - 5% al TOTAL TUA BON 3.73 2:0764 BF +0049 AR. ANEF 0001, iD BF: 3000856168202 1 129015100807640049 DATA: 30-12-2021 ORA: 15:10:08";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}