package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\banh\b`)
var str = `anh yêu thanh nhiều lắm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}