$re = '/(?(DEFINE)(?\'pat\'a|ab))^(?P>pat)b$/';
$str = 'ab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);