import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([NnSs\\+-])?([0-8]?\\d(\\.\\d*)?|90) *([°˚º^~*]*) *([NnSs\\+-])*)([,:;\\s|\\/\\\\-]+)(([EeWw\\+-]*)([0]?\\d?\\d(\\.\\d*)?|1[0-7]\\d(\\.\\d*)?|180) *([°˚º^~*]*) *([EeWw\\+-]*))$";
final String string = "53.651231°N 113.641376°W\n\n"
+ "57.084599°N 2.783300°W";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}